OpenWRT wireless

# configure wifi
uci set wireless.radio0.disabled=0
uci set wireless.radio0.channel=5
uci set wireless.@wifi-iface[0].encryption=psk2
uci set wireless.@wifi-iface[0].ssid=$(uci get wireless.radio0.macaddr | tr -d ":" | tr "a-z" "A-Z")
uci set wireless.@wifi-iface[0].key="t00r"

# enable mac filter
uci set wireless.@wifi-iface[0].macfilter=allow
#broken#uci set wireless.@wifi-iface[0].maclist="00:a1:a2:a3:a4:a5 00:b1:b2:b3:b4:b5"

# commit changes
uci commit wireless
wifi

# remove all mac addresses
uci del wireless.@wifi-iface[0].maclist

# add read allowed mac addresses

/etc/config/network

config interface loopback
option ifname lo
option proto static
option ipaddr 127.0.0.1
option netmask 255.0.0.0

config interface eth
option ifname eth0

config interface lan
option ifname "lan1 lan2 lan3 lan4"
option type bridge
option proto static
option ipaddr 192.168.2.254
option netmask 255.255.255.0

config interface wan
option ifname wan
option proto dhcp

Install Eclipse

<?php
$URL="https://raw.githubusercontent.com/panticz/installit/master/install.eclipse.sh";
echo "wget -q $URL -O - | bash -";
echo "

";
$c = curl_init();
curl_setopt($c, CURLOPT_URL, $URL);
curl_setopt($c, CURLOPT_RETURNTRANSFER, 1);
echo htmlspecialchars(curl_exec($c));
curl_close($c);
echo "

";
?>

Git plugin
# http://www.vogella.com/tutorials/EclipseGit/article.html
http://download.eclipse.org/egit/updates

WindowBuilder (Java GUI creator plugin)
http://www.eclipse.org/windowbuilder/

sudo eclipse
install new software:
http://download.eclipse.org/windowbuilder/WB/release/R201209281200/4.2/

Global settings
/usr/lib/eclipse/eclipse.ini

OPTIONAL: change editor line break to 240 char
Project > Properties
Configure Worksapece Settings
Edit
Line Wraping
Maximum line widht: 240

Links
http://www.youtube.com/watch?v=WY9QbOdWkn0 - create Java Gui Tutorial (german)
http://code.google.com/intl/de/eclipse/docs/install-eclipse-3.5.html
http://sourceforge.net/projects/shelled/

Fix unable to shutdown / reboot / logout when OpenOffice Quickstarter is active

Here is a quick fix for OpenOffice bug reported on Launchpad https://bugs.edge.launchpad.net/ubuntu/+source/openoffice.org/+bug/562027 that prevent Gnome logout if Quickstart is running.

Solution: change DocumentStoreUIEnabled in Recovery.xcu (OpenOffice) or main.xcd (Libreoffice) to false with this command

<?php
$URL="http://dl.panticz.de/libreoffice/scripts/DocumentStoreUIEnabled_false.sh";
echo "wget $URL -O - | bash -";
echo "

";
$c = curl_init();
curl_setopt($c, CURLOPT_URL, $URL);
curl_setopt($c, CURLOPT_RETURNTRANSFER, 1);
echo htmlspecialchars(curl_exec($c));
curl_close($c);
echo "

";
?>

or use Diff to path Recovery.xcu
wget -nv http://dl.dropbox.com/u/4170695/openoffice/Recovery.xcu_DocumentStoreUIEnabled.diff -O - | \
patch -p2 /usr/lib/openoffice/basis3.2/share/registry/data/org/openoffice/Office/Recovery.xcu

Optional: remove user personal Recovery.xcu files
find /home/*/.openoffice.org/ -name Recovery.xcu -exec rm {} \;

Links
https://bugs.launchpad.net/ubuntu/+source/openoffice.org/+bug/562027

Magento: Price on request / Preis auf Anfrage

# create file: default.phtml.price-on-request.diff
--- /var/www/app/design/frontend/base/default/template/checkout/cart/item/default.phtml 2010-09-30 12:19:38.000000000 +0200
+++ /var/www/app/design/frontend/default/default/template/checkout/cart/item/default.phtml 2010-09-30 12:22:33.000000000 +0200
@@ -121,11 +121,15 @@

<?php endif; ?>

+ <?php if ($_item->getPrice() > 0): ?>
<?php if (Mage::helper('weee')->typeOfDisplay($_item, array(0, 1, 4), 'sales') && $_item->getWeeeTaxAppliedAmount()): ?>
<?p

Install PHP accelerator php APC

apt-get install -y php-apc

# configure apc
echo "apc.shm_size=128" >> /etc/php5/conf.d/apc.ini

# configure kernel shm
cat <> /etc/sysctl.conf
kernel.shmall = 134217728
kernel.shmmax = 134217728
EOF
sysctl -p /etc/sysctl.conf

# restart apache
/etc/init.d/apache2 restart

# configure magento to use apc
cp /var/www/app/etc/local.xml.additional /var/www/app/etc/local.xml.additional.org
diff ./app/etc/local.xml.additional.org ./app/etc/local.xml.additional -Naur
--- ./app/etc/local.xml.additional.org 2011-09-08 11:38:11.000000000 +0200
+++ ./app/etc/local.xml.additional

install eclipse gwt plugin

# check for new version
https://developers.google.com/eclipse/docs/download

# run eclipse as root
sudo /usr/lib/eclipse/eclipse

# install GWT plugin
Help > Install New Software
Work with: http://dl.google.com/eclipse/plugin/4.2
Add
OK
Select:
Google Plugin for Eclipse (required)
GWT Designer for GPE (recommended)
SDKs
Next >

# GWT Designer
Help > Install New Software
Work with: http://dl.google.com/eclipse/inst/d2gwt/latest/3.7

# beta
https://developers.google.com/web-toolkit/tools/download-gwtdesigner-beta
...

# Links
~/.mozilla/firefox/*/extensions/gwt-dev-plug

HUAWEI K3765-HV

sudo apt-get install -y usb-modeswitch

cat <> /etc/udev/rules.d/usb_modeswitch.rules
# HUAWEI K3765-HV
SUBSYSTEM=="usb", SYSFS{idVendor}=="12d1", SYSFS{idProduct}=="1520", RUN+="/usr/sbin/usb_modeswitch --default-vendor 0x12d1 --default-product 0x1520 -M 55534243EE0000006000000000000611062000000000000000000000000000"
SUBSYSTEM=="usb", SYSFS{idVendor}=="12d1", SYSFS{idProduct}=="1465", RUN+="/sbin/modprobe -r option"
SUBSYSTEM=="usb", SYSFS{idVendor}=="12d1", SYSFS{idProduct}=="1465", RUN+="/sbin/modprobe usbserial vendor=0x12d1 product=0x1465"
EOF

sudo reload udev

# Links
h